UDPXY - T-2 IP TV na računalniku preko WiFi (OpenWRT)

|     Prva stran     |     Dolpoteg     |     Galerija     |     Kontakt     |

 

Usmerjevalnik z OpenWRT FW-jem bomo skonfigurirali, da bomo na računalniku lahko spremljali TV programe, ki jim imamo naročene. Navodila so objavljena na OpenWrt spletni strani. Potrebovali bomo brezplačno orodje WinSCP, ki ga dobite tukaj. IPTV bo delovala žično in preko WiFi.

Za vodič sem uporabil TP-Linkov router model TL-WR841N v. 12 z nameščenim LEDE OpenWRT FW-jem;

Kot sem že omenil, je osnova za ta vodič spletna stran http://wiki.openwrt.org/doc/howto/udp_multicast;

Ok, začnimo ... Najprej moramo na router inštalirati nekaj programske opreme. Prijavimo se v router in odklikamo v System, Software ;

Klik na gumb Update lists ;

Počakamo na obvestilo o prenešenih podatkih o razpoložljivih paketih, nakar kliknemo na Available packages ;

V polje Filter vpišemo kmod-bridge in kliknemo na gumb Find package ;

Počakamo na rezultat iskanja, nakar kliknemo na Install pred paketom kmod-bridge;

Klik na gumb OK ;

Počakamo, da se izpiše obvestilo o poteku namestitve, nakar kliknemo Available packages ;

Tokrat v polje Filter vpišemo igmpproxy, kliknemo Find package, Install pred najdenim paketom, OK in počakamo obvestilo o namestitvi paketa;

Ponovimo vajo z iskanjem paketa udpxy ;

Tokrat bo iskanje postreglo z več zadetki. Večinoma so v uporabi OpenWRT FW-ji z nameščenim Luci grafičnim vmesnikom (ta GUI je tudi v mojem primeru), zato bomo inštalirali luci-app-udpxy , da bomo kasneje udpxy lahko nastavili preko grafičnega vmesnika;

Ko je namestitev končana oz. dobimo obvesilo o namestitvi, reštartamo router ;

Ko se router ponovno "postavi", zaženemo WinSCP ;

Izberemo protokol SCP ;

Vpišemo naslov routerja , uporabniško ime in geslo , ter kliknemo gumb Login ;

Pojavilo se bo opozorilno okno, kjer kliknemo gumb Yes ;

Pojavi se okno, kjer je oz. bo na desni strani vidna vsebina našega routerja. Kliknite drsnik in izberite /<root> ;

Pojdimo v mapo etc ;

Mapa config ;

Desnokliknemo na datoteko igmpproxy in izberemo možnost Edit;

Vsebino datoteke spremenimo z naslednjim tekstom;

config igmpproxy
option quickleave 1

config phyint
option network wan
option direction upstream
list altnet 0.0.0.0/0

config phyint
option network lan
option direction downstream

Shranimo ;

Zapremo okno ;

Uredimo datoteko network. Desnoklik, Edit ;

Pod opcijo config interface lan dodamo;

option igmp_snooping 1

in spremembo shranimo, nakar zapremo okno;

Naslednja datoteka, ki jo moramo urediti je firewall. Desnoklik, Edit;

Dodamo naslednji tekst;

config rule
option src wan
option proto igmp
option target ACCEPT
config rule
option src wan
option proto udp
option dest lan
option dest_ip 224.0.0.0/4
option target ACCEPT
config rule
option src wan
option proto udp
option dest_ip 224.0.0.0/4
option target ACCEPT

Nakar spremembo shranimo in zapremo okno;

Iz mape config moramo nivo višje v vsebino mape etc ;

Desnoklik in Edit na datoteko rc.local ;

Vnesemo;

echo "0" > /sys/devices/virtual/net/br-lan/bridge/multicast_snooping

Spremembo shranimo in zapremo okno;

WinSCP-ja ne bomo več potrebovali. Zaključimo sejo in program zapremo;

Ponovno se prijavimo v router in ga reštartamo ;

Ko se router postavi, lahko spremljamo IPTV na računalniku preko multicasta;

Nastavimo še udpxy. Prijavimo se v router, izberimo Services , udpxy ;

Kljukica v polje Enabled, po želji nastavite oz. spremenite port, na katerem bo deloval udpxy in klik na gumb Save & Apply ;

* v polju Max clients lahko omejimo število hkratnih odjemalcev.

Uživajte v IPTV-ju preko udpxy;

 

** na routerju Xiaomi MiWiFi mi je na zgoraj opisan način IP TV na računalniku delovala zgolj preko udpxy, preko multicasta pa ne. Rešitev - v datoteko /etc/sysctl.conf sem moral z zgoraj opisanim postopkom z uporabo WinSCP-ja dodati ukaz;

net.ipv4.conf.all.force_igmp_version=2

 

 

Na vrh

www.oyoy.si - vse pravice pridržane.